PHP is amongst the most commonly used dynamic programming languages. It’s highly popular since it is free software, which you can use to set up interactive sites like social networking sites, online stores or e-teaching portals rather than static HTML-based websites. A PHP module must be present on the web server where a PHP-driven site is hosted so that its PHP code can be ‘decrypted’. As there are no license charges for this sort of module and the language offers innumerable options for the applications that you develop, there’re hundreds of millions of PHP websites. What is more, there’re a ton of open-source PHP-based scripts, which you can use for your websites without needing to have any programming abilities. Considering the fact that there’re different versions of PHP, you ought to confirm if the same exact version that you used whilst building your site is installed on the server as well.

PHP 4, PHP 5 and PHP 7 Support in Web Hosting

With our web hosting packages, you will be able to select which version of PHP will be enabled for your hosting account, as different versions are activated on our servers. With just one click of the mouse, you will be able to switch between PHP 4, 5, 7 and whenever a new version is unveiled in the future, we will add it to the Hepsia hosting Control Panel without removing the earlier versions. In this way, you’ll be able to host all the sites that you’ve developed throughout the years. In stark contrast with many other hosting suppliers, we won’t force you to update such sites, as a script may be out of date, but this doesn’t necessarily mean that it’s vulnerable since you may have implemented modifications to its code to repair safety breaches. For the sake of your convenience, you’ll even be able to specify a different PHP version for each website that you host in your hosting account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

We’re unwavering in our belief that several years spent creating a site shouldn’t be lost, which goes to say that in case you get a semi-dedicated server from us, you’ll be able to use any script, irrespective of whether it’s new or old. In contrast with a lot of hosting vendors, we support a number of different PHP versions on our state-of-the-art cloud hosting platform – 4, 5 and 7. Not only will you be able to activate the version that you need from your Hepsia Control Panel, but you’ll also have the option to set a different version for each single website. This can be done merely by placing an .htaccess file inside the root directory of the given site. You can change the version either for a single site or for the whole account and the change will take effect in less than several minutes. With our hosting services, you can be certain that you will never confront any website compatibility problems.